converting to net 4.0

Dec 21, 2011 at 10:34 PM

iv'e used your 2.0 version & need to update to 4.0 (ability to use LINQ).  i've removed the old andersonimes reference, installed the package, added the reference to ServiceProcess.Helpers.  it compiles without err, but when the debugger starts i get nothing- no errors & doesn't reach the Sub Main.  I'm using VB, but that shouldn't matter.

i see in the discussion something autostart, but where's that?

thx in advance

Coordinator
Dec 21, 2011 at 10:44 PM

If you never see any breakpoints hit in your Sub Main, there's likely something else going wrong. Possibly a project setting?

Dec 22, 2011 at 1:12 AM

I started a new service project and everything works like it should.  I guess there is something in the upgrade process from VS2005 to VS2010 and 2.0 to 4.0 that doesn't sync up correctly.  I'll just move my code from the old solution to the new one.  I'm not inclined to try to find the problem & it would be waste of time.

Jim